Home > Cannot Find > Php Compile Cannot Find Mysql Header Files Under

Php Compile Cannot Find Mysql Header Files Under

Contents

My Online Diary Adv Reply Quick Navigation Packaging and Compiling Programs Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums The Ubuntu Forum Community Ubuntu Visit the following links: Site Howto | Site FAQ | Sitemap | Register Now If you have any problems with the registration process or your account login, please contact us. Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ I've tried everything and still no go. http://rss4medics.com/cannot-find/php-cannot-find-mysql-header-files.php

no configure: error: wrong mysql library version or lib not found. Please try with current MySQL 5.0.41 and if you can repeat described behaviour send us result of the command /usr/bin/mysql_config [17 May 2007 1:35] Juan Montesinos Hello, I just installed the Not the answer you're looking for? How do I make an alien technology feel alien? http://www.linuxquestions.org/questions/linux-software-2/php5-configure-error-cannot-find-mysql-header-files-230651/

Configure: Error: Cannot Find Libmysqlclient Under /usr.

I am trying to install php from source. Thanks In ssx/genv2.cpp you might need to add #include to fix an compile error of strcmp Last edited by rajeshgautam; August 5th, 2011 at 12:28 PM. Ballpark salary equivalent today of "healthcare benefits" in the US?

Simply do: brew update && brew upgrade brew install php54 If building php with old libmysql is really required, then try the following: brew update && brew upgrade brew install mysql Share a link to this question via email, Google+, Twitter, or Facebook. So I just downloaded the mysql source for a newer version 4.1 instead of 4.0 and configured and installed it. How To Find Mysql Header Files Alternating Fibonacci more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture /

I have all the dependencies installed (finally lol) however i am having an issue with the configuration finding the mysql header files. Note That The Mysql Client Library Is Not Bundled Anymore! Subscribed! In Debian or Ubuntu: aptitude install libmysql++-dev Telmo Lemos da Rosa Originally Posted by biker007fr Hi everyone! http://unix.stackexchange.com/questions/23870/troubles-installing-php-with-mysql-support thanks.

If configure has finished running and produced a Makefile, then run make distclean. Configure Error Cannot Find Mysql Header Files Under Usr Share Mysql checking for mSQL support... What now? The configure program keeps a cache of what it's found, and sometimes won't realize that the cache is no longer up-to-date.

Note That The Mysql Client Library Is Not Bundled Anymore!

Is making now, can take some time on the old K6-II 300MHz. (making mysql took almost an hour ) thanks for the replies. https://github.com/Homebrew/homebrew-php/issues/1090 Can I use that to take out what he owes me? Configure: Error: Cannot Find Libmysqlclient Under /usr. steriojose View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by steriojose 07-09-2007, 03:18 PM #13 kplimack LQ Newbie Registered: Jul 2007 Posts: Configure: Error: Cannot Find Mysql Header Files Under /usr/include/mysql Should I allow my child to make an alternate meal if they do not like anything served at mealtime?

no configure: error: mysql configure failed. http://rss4medics.com/cannot-find/php-cannot-find-mysql-header.php bathory View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by bathory 09-15-2004, 06:31 AM #4 ldp Member Registered: Apr 2004 Location: Belgium Thanks in advance 12.04 mysql php share|improve this question edited Feb 19 '13 at 8:40 Nitin Venkatesh 12.6k84979 asked Feb 19 '13 at 7:58 sede 612 look here forums.debian.net/viewtopic.php?t=9636 C# TBB updating metadata value How often should I replace windscreen wiper blades? Install Mysql Header Files Ubuntu

ldp View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by ldp 09-15-2004, 05:52 AM #3 bathory LQ Guru Registered: Jun 2004 Location: Note that the MySQL client library is not bundled anymore. LLS View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by LLS 11-16-2004, 07:25 PM #8 teddyted LQ Newbie Registered: Nov 2004 Location: navigate here Should I allow my child to make an alternate meal if they do not like anything served at mealtime?

I have to make php with the mysql option to use my mysql database but there is something wrong and I didn't find the solution... Configure: Error: Cannot Find Libpq-fe.h. Please Specify Correct Postgresql Installation Path no checking for MySQL UNIX socket location... no checking for MySQLi support...

Do I have to reinstall MySQL? "Share your Experience!" Thanks, Teddy I had the same problem too, on Debian Woody 3.0.

Are you new to LinuxQuestions.org? Ask Ubuntu works best with JavaScript enabled Login / Register Developer Zone Bugs Home Report a bug Statistics Advanced search Saved searches Tags Bug#28480 error when compiling php 5.2.2 with --with-mysql here is where it gets odd: $ cd /usr/include/mysql $ ll | grep mysql.h -rw-r--r-- 1 root root 28148 May 11 2011 mysql.h clearly the header files are present. Libmysqlclient-dev no checking for MySQLi support...

Note that the MySQL client library is not bundled anymore!" "$LINENO" 5 fi the error is misleading in that it simply prints what you entered; $PHP_MYSQL and doesn't tell you that Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up using Facebook Sign up using Email and Password Post as a guest Name So I changed my command to: ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql --with-zlib Now I just get this: configure: error: mysql configure failed. his comment is here Please check config.log for more information. /////////////////// Also I used the 2nd parameter in the configure script: ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysqli=/usr/local/mysql/bin/mysql_config --with-pgsql --with-pear --with-openssl --with-bz2 --with-gd --with-ttf --with-png-dir --with-jpeg-dir --with-gettext --with-ldap --with-imap-ssl

Browse other questions tagged linux apache-httpd mysql php or ask your own question. asked 3 years ago viewed 4243 times active 3 years ago Related 0MySQL access via PHP doesn't find database4Why can't I install php-mysql?1how to install apache/php from apt alongside mysql 5.6 Here's the sections I think may be relevant: configure:60061: gcc -o conftest -I/usr/include -g -O2 -fvisibility=hidden-Wl,-rpath,/usr/lib/mysql -L/usr/lib/mysql -L/usr/lib conftest.c -lmysqlclient -lz -lrt -lm -ldl -lnsl -lxml2 -lz -lm -lxml2 -lz -lm Thanks so much.

On which point(s) in a jet engine does the reaction force act? no configure: error: wrong mysql library version or lib not found. How do pilots identify the taxi path to the runway? Already have an account?

Having a problem logging in? To start viewing messages, select the forum that you want to visit from the selection below. yes checking whether to enable embedded MySQLi support... Thx Maz Adv Reply December 12th, 2007 #2 dholbach View Profile View Forum Posts Private Message Visit Homepage Ubuntu Member Join Date Oct 2007 Location Berlin, Germany Beans 84 Re:

On 1941 Dec 7, could Japan have destroyed the Panama Canal instead of Pearl Harbor in a surprise attack? no checking for MSSQL support via FreeTDS... Start a coup online without the government intervening Is Area of a circle always irrational Absolute values of complex irreducible characters of finite groups What legal documents are Italian citizens supposed I know that between PHP 5.3 and 5.4 PHP moved from libmysqlslient to mysqlnd [whatever that means], but according to their manual the compile arguments have not changed.

Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the Oracle SQL - can I return the "before" state of a column value Wrong way on a bike lane? How do I "lock" my Linux box for few hours? 301RedirectModule isn't working for URL with dot file name Using DSolve with a boundary condition at -Infinity What legal documents are I ran: brew install php54 --with-debug --with-libmysql Full output: => Downloading http://www.php.net/get/php-5.4.27.tar.bz2/from/this/mirror Already downloaded: /Library/Caches/Homebrew/php54-5.4.27 Warning: Backing up all known pear.conf and .pearrc files Warning: If you have a pre-existing pear

no checking for mysql_error in -lmysqlclient... THANK YOU Reply With Quote 07-25-2007,08:47 AM #5 kurund View Profile View Forum Posts Junior Member Join Date Jul 2007 Posts 1 create symb link for mysql_config sudo ln -s /usr/local/mysql/bin/mysql_config