Home > Cannot Find > Php Configure Cannot Find Libmysqlclient Under /usr

Php Configure Cannot Find Libmysqlclient Under /usr

Contents

But removing apparently works, but you'll want to make sure this didn't break any functionality for PHP with a MySQL database as well. Tiyogi Linux - Software 4 05-04-2004 08:24 AM Can't find php configure NW Otter Linux - Software 1 09-24-2003 01:33 AM All times are GMT -5. Show that the square matrix A is invertible As a monk, can I use Deflect Missiles to intentionally catch a projectile? yes no [2006-01-18 22:14 UTC] chris at spawnordie dot com Description: ------------ Please accept my apologies if this is already reported - I searched and didn't find it. http://rss4medics.com/cannot-find/php-configure-cannot-find-libmysqlclient.php

Did you compile libmysql or install from repo? –beiller Sep 9 '14 at 15:44 Using Ubuntu, I installed libmysql from repo. –inimrepus Sep 9 '14 at 15:45 1 I had managed to have php5.2 and php5.3 on ubuntu 11.10 –farzam Jun 21 '12 at 9:10 2 @fkniya: You should not care about a single downvote too much. Someone peeled an American flag sticker off of my truck. It's using multiple php engines at apache at the same time.

Cannot Find Mysql Header Files Under

Note that the MySQL client library is not bundled anymore! It's not our fault if they do things wrong. [2010-03-25 18:32 UTC] michael at michaelsnet dot us IMHO this is a documentation bug. I stumbled upon this via this stackoverflow question (http://stackoverflow.com/questions/1...urce-on-ubuntu).

Can I use that to take out what he owes me? This article was written before we started using a custom method to wrap code. For Ubuntu Precise, I had to use "--with-libdir=/lib/x86_64-linux-gnu". Checking For Specified Location Of The Mysql Unix Socket... No The APC, memcache, and memcached modules can be installed through PEAR which we must install and initialize first: apt-get -y install php-pear cd /opt/phpfcgi-5.3.22/etc pecl -C ./pear.conf update-channels APC can now

Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up using Facebook Sign up using Email and Password Post as a guest Name Cannot Find Libmysqlclient_r PHP Build Error: bash configure: error: Cannot find libmysqlclient under /usr. yes checking for specified location of the MySQL UNIX socket... configure.sh failed.

I only see the path inside the error messages of the # ldconfig -v | grep mysql output, but it has other paths, too. –hakre Jun 21 '12 at 9:22 Note That The Mysql Client Library Is Not Bundled Anymore! but I have to have this on my machine to support legacy scripts. Do humans have an ethical obligation to prevent animal on animal violence? UX team under Product management or Engineering or an Independent?

Cannot Find Libmysqlclient_r

Browse other questions tagged php ubuntu installation or ask your own question. Note that the MySQL client library is not bundled anymore! Cannot Find Mysql Header Files Under share|improve this answer edited Sep 9 '14 at 16:48 answered Sep 9 '14 at 15:41 beiller 2,6621415 I tried this but it did not work unfortunately. –inimrepus Sep 9 Php Cannot Find Libmysqlclient_r Join our community today!

Last updated: Thu Nov 10 11:01:49 2016 UTC his comment is here Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community. On which point(s) in a jet engine does the reaction force act? magento 2: How to use the order by and limit clause in sql query Absolute values of complex irreducible characters of finite groups more hot questions question feed lang-php about us Configure Error Cannot Find Mysql Header Files Under Usr Bin

asked 2 years ago viewed 2950 times active 2 years ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Linked 10 Cannot find libmysqlclient under /usr. while build PHP 5.2 from source on Ubuntu 12.4122error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'1ln: /usr/lib/libmysqlclient.18.dylib: File exists3EnvironmentError: mysql_config not found0Cannot find libmysqlclient under /usr0libmysqlclient on Android GarrathE View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by GarrathE 07-15-2011, 01:31 AM #8 iforce2d LQ Newbie Registered: Jul 2011 Posts: this contact form Thanks again!

The users who voted to close gave this specific reason:"Questions should demonstrate reasonable business information technology management practices. Install Libmysqlclient neocontrol View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by neocontrol 09-07-2007, 03:56 PM #2 trickykid LQ Guru Registered: Jan 2001 Posts: alex Reply Artorios Rex 2:28 AM March 5, 2011 Sorry, Alex.

This is really an annoying issue, as I run into this every time, and I continue to have to come up with different solutions.

Php 5.5.9 is working fine on my machine. I invite the reviewer to explain either why the documentation is incorrect about the function of --with-libdir or why it is not respected in regards to mysql at his leisure. share|improve this answer answered Nov 8 '09 at 20:45 johannes 40019 add a comment| up vote 1 down vote Maybe for some poor soul this will work: ./configure --with-apxs2=/usr/sbin/apxs --with-mysql=mysqlnd --with-mysqli=mysqlnd Configure: Error: Cannot Find Openssl's Libraries And, based on the fact that I provided a work-around, it should have been clear that I did, in fact, know what I was doing.

while build PHP 5.2 from source on Ubuntu 12.4 Related 13CLSQL and MYSQL on OS X62Ruby gem mysql2 install failing1building mysql client library with ssl support10Cannot find libmysqlclient under /usr. and add the line extension=memcached.so at the end of the file: [...] extension=memcached.so The ionCube Loader can be installed as follows: cd /tmp Next download and unpack the correct ionCube Loader yes no Are you using the same operating system? navigate here Thanks!

Thanks. make make install Copy php.ini to the correct location: cp /usr/local/src/php5-build/php-5.3.22/php.ini-production /opt/phpfcgi-5.3.22/lib/php.ini That's it - if you like, you can now install some additional modules like APC, memcache, memcached, and ioncube. GO OUT AND VOTE How would you model 'a sphere with a shell' like object? current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list.

I should have clarified that in the second comment. C++ calculator using classes How do I make an alien technology feel alien? vi /opt/phpfcgi-5.3.22/lib/php.ini ... What is a satisfactory result of penetration testing assessment?

What a fantastic long life posting from ARUNR in 2009. Why is the 'You talking to me' speech from the movie 'Taxi Driver' so famous? Quote: ./configure --with-mysql=/usr/bin/ --with-libdir=lib64 Hope that helps! Should I report it?

Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Note that the MySQL client library is not bundled anymore! Would we find alien music meaningful? This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant.

Despite being told by the configuration option --with-libdir=lib64 to use lib64/ it still chooses to use lib/ and fails to find the necessary files to continue with the ./configure. Note that the MySQL client library is not bundled anymore! Last edited by neocontrol; 09-07-2007 at 11:22 AM. Thank you so much!