Home > Cannot Find > Php Error Cannot Find Libmysqlclient Under /usr

Php Error Cannot Find Libmysqlclient Under /usr

Contents

All Rights Reserved. For Ubuntu Precise, I had to use "--with-libdir=/lib/x86_64-linux-gnu". Thanks. Join them; it only takes a minute: Sign up Cannot find libmysqlclient under /usr. this contact form

Are you new to LinuxQuestions.org? Note that the MySQL client library is not bundled anymore! yes checking for specified location of the MySQL UNIX socket... Note that the MySQL client library is not bundled anymore! Проверяем где находятся библиотеки mysql: # ldconfig -v |grep mysql libmysqlclient_r.so.16 -> libmysqlclient_r.so.16.0.0 libmysqlclient.so.18 -> libmysqlclient_r.so.18.0.0 libmysqlclient.so.15 -> libmysqlclient.so.15.0.0 libmysqlclient.so.16 -> http://stackoverflow.com/questions/11134220/cannot-find-libmysqlclient-under-usr-while-build-php-5-2-from-source-on-ubuntu

Cannot Find Mysql Header Files Under

Reply alex 2:29 PM March 7, 2011 Hello Artorios Rex, No worries man! I only added: --with-libdir=lib64 This helped me! Click here to see the post LQ members have rated as the most helpful post in this thread. while build PHP 5.2 from source on Ubuntu 12.4122error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'1ln: /usr/lib/libmysqlclient.18.dylib: File exists3EnvironmentError: mysql_config not found0Cannot find libmysqlclient under /usr0libmysqlclient on Android

Is there still a way to prevent Trump from becoming president? Should I report it? no configure: error: Cannot find libmysqlclient_r under /usr/local/mysql. Checking For Specified Location Of The Mysql Unix Socket... No neocontrol View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by neocontrol 09-07-2007, 03:56 PM #2 trickykid LQ Guru Registered: Jan 2001 Posts:

Please check your c-client installation. [emailprotected]:/usr/local/src/php5-build/php-5.3.22# ) Configure and build PHP 5.3.22 as follows (you can adjust the ./configure command to your needs, take a look at ./configure --help to see I mean the exact path. thanks for pointing out. LinuxQuestions.org > Forums > Linux Forums > Linux - Server php configure: cannot find libmysqlclient User Name Remember Me?

Was stuck with compiling php 5.3.29 for phpfarm usage. Note That The Mysql Client Library Is Not Bundled Anymore! while build PHP 5.2 from source on Ubuntu 12.4 Updated from your comment! How to help configure find it? [email protected] View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by [email protected] 11-17-2009, 05:52 AM #4 augustofagioli LQ Newbie Registered: Nov 2009 Posts:

Cannot Find Libmysqlclient_r

What is this line of counties voting for the Democratic party in the 2016 elections? Browse other questions tagged mysql php or ask your own question. Cannot Find Mysql Header Files Under So here I am installing php with these terms: Code: ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-libdir=/usr/lib/mysql --with-mysql --with-mysqli --with-mcrypt=/usr/local --with-pear=/usr/local/apache2/php --with-bz2=/usr --enable-sockets --enable-dbx --enable-dbase --with-zlib --enable-mbstring --with-curl=/usr/local/bin/ And here's what it spits out at Php Cannot Find Libmysqlclient_r This entry was posted in LAMP by Arun Ghosh.

asked 7 years ago viewed 5717 times active 1 year ago Visit Chat Related 0Compiling PHP 5.1.6 with PDO MySQL2Best Practices for installing PHP5 and MySQL5 on Red Hat Enterprise Linux weblink Note that the MySQL client library is not bundled anymore! Password Linux - Server This forum is for the discussion of Linux Software used in a server related context. PHP 5.3.22) - this PHP version will be listed under this name in the website settings in ISPConfig: Go to the FastCGI Settings tab (the PHP-FPM Settings tab can be left Configure Error Cannot Find Mysql Header Files Under Usr Bin

Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the Here's the output of ldconfig which only has one /usr listed. No, create an account now. navigate here make make install Copy php.ini to the correct location: cp /usr/local/src/php5-build/php-5.3.22/php.ini-production /opt/phpfcgi-5.3.22/lib/php.ini That's it - if you like, you can now install some additional modules like APC, memcache, memcached, and ioncube.

I neglected to use & lt; and & gt; entities in my first comment and couldn't edit it to put them in. Install Libmysqlclient When I compile PHP 5.3.10. EDIT2: tried running ldconfig -v |grep mysql and here is the output # ldconfig -v |grep mysql /sbin/ldconfig.real: Path `/lib/x86_64-linux-gnu' given more than once /sbin/ldconfig.real: Path `/usr/lib/x86_64-linux-gnu' given more than once

also I'm running a 64bit version of ubuntu.

vi /opt/phpfcgi-5.3.22/lib/php.ini ... How can an advanced (circa 7000 AD) spacefaring human civilization be prevented from entering its own solar system? Lab colleague uses cracked software. Configure: Error: Cannot Find Openssl's Libraries The APC, memcache, and memcached modules can be installed through PEAR which we must install and initialize first: apt-get -y install php-pear cd /opt/phpfcgi-5.3.22/etc pecl -C ./pear.conf update-channels APC can now

How to delete the lines from a file that do not contain dot? Can negative numbers be called large? Artorios Rex 11:54 AM March 1, 2011 You may want to encapsulate the code with tags... his comment is here Having a problem logging in?

Not the answer you're looking for? no checking for MySQL support... Thanks. EDIT1: I minimized the configure command so it just focuses to mysql.

here is the command I used and it works: sudo ./configure --prefix=/opt/php5.2 --with-config-file-path=/opt/php5.2 --with-mysql --with-libdir=/lib/x86_64-linux-gnu share|improve this answer answered Jun 21 '12 at 9:16 farzam 4402516 How did you php mysql ubuntu-12.04 share|improve this question asked Feb 19 at 7:25 lalit 11 add a comment| active oldest votes Know someone who can answer? But I am not able to make mysql connection for PHP 5.3.10. yes checking for libmcrypt version... >= 2.5.6 checking for mcrypt_module_open in -lmcrypt...

Why were pre-election polls and forecast models so wrong about Donald Trump? Now it works! Thank you so much! When you do compile this it's called the PHP LSAPI module which is then used by Litespeed to process PHP.

Thanks again! no checking for MySQL UNIX socket location... /var/lib/mysql/mysql.sock configure: error: Cannot find libmysqlclient under /usr. vi /opt/phpfcgi-5.3.22/lib/php.ini ... Browse other questions tagged php mysql ubuntu-12.04 or ask your own question.