Home > Cannot Find > Pkg-config Cannot Find Openssl

Pkg-config Cannot Find Openssl

Contents

I installed the following dependencies before installing mongodb sudo apt-get install -y autoconf g++ make openssl libssl-dev libcurl4-openssl-dev pkg-config libsasl2-dev libpcre3-dev sudo pecl install mongodb share|improve this answer edited Feb 23 yum install openssl-devel share|improve this answer answered Dec 1 '14 at 6:55 xavierzhao 336312 add a comment| up vote 2 down vote If you can use pkg-config: pkg_search_module() can find OpenSSL more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed How to fix?0using RC4 in Openssl on Ubuntu instead of Camellia5apt-get upgrade openssl won't bring Ubuntu 12.04 to latest version0./configure says OpenSSL is missing, but it isn't5Unable to configure qemu on this contact form

checking OPENSSL_LIBS... -lssl -lcrypto checking for OpenSSL... How do I "lock" my Linux box for few hours? The SASL library path should contain include/sasl/sasl.h within it. cmake -DOPENSSL_ROOT_DIR=/usr/local/ssl -DOPENSSL_LIBRARIES=/usr/local/ssl/lib share|improve this answer edited Apr 27 '13 at 17:47 answered Apr 27 '13 at 6:54 Morwenn 9,15654297 1 one more problem .. https://github.com/mongodb/mongo-php-driver/pull/138

Configure: Error: Cannot Find Openssl's Libraries Centos

linux openssl share|improve this question edited Jul 2 '13 at 0:52 Bradd Szonye 591213 asked Dec 27 '11 at 9:51 P K 56821628 add a comment| 5 Answers 5 active oldest Browse other questions tagged php openssl or ask your own question. current community blog chat Super User Meta Super User your communities Sign up or log in to customize your list.

If that didn't work for you check the wiki page, it will help you figure out what paths to put. And you can also build your openssl as shared. [origin]:~ $ ll /usr/local/ssl/lib/ total 13904 -rw-r--r-- 1 root sys 4021732 Okt 16 11:27 libcrypto.a lrwxr-xr-x 1 root sys 14 Okt 16 Terms Privacy Security Status Help You can't perform that action at this time. Configure: Error: Cannot Find Openssl's Ubuntu As a monk, can I use Deflect Missiles to intentionally catch a projectile?

Do humans have an ethical obligation to prevent animal on animal violence? Configure: Error: Please Reinstall The Bzip2 Distribution pkg-config doesn't know anything about libcog. You might try to fix by runing ldconfig manually. http://superuser.com/questions/371901/openssl-missing-during-configure-how-to-fix What now?

apt-get install pkg-config [2015-04-23 10:35 UTC] mail at cebe dot cc -Status: Open +Status: Closed [2015-04-23 10:35 UTC] mail at cebe dot cc closing this then, sorry for the noise. Phpbrew Configure: Error: Cannot Find Openssl's Libraries Those folders are "prefix". I don't think I will be able to help you more than that, sorry :/ –Morwenn Apr 27 '13 at 17:46 add a comment| up vote 39 down vote I had more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Configure: Error: Please Reinstall The Bzip2 Distribution

yes checking for pkg-config... Unexpected Delay Between For Loops Is there a word for being sad about knowing that the things that make you happy will eventually go away Boss sends a birthday message. Configure: Error: Cannot Find Openssl's Libraries Centos why is rdsk not available on linux? Configure: Error: Cannot Find Openssl's Mac share|improve this answer answered Oct 18 '15 at 20:36 user510433 2615 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign

Then if you install software outside the default list of folders you had to "adjust" the list, namely add your directories to PKG_CONFIG_PATH $ export PKG_CONFIG_PATH=$PKG_CONFIG_PATH: For more info, you can http://rss4medics.com/cannot-find/phpize-cannot-find-config.php It does not affect pkg-specific things like library search directories. –underscore_d Sep 13 '15 at 19:43 add a comment| up vote 2 down vote I looked at the man-page on my Devidian commented Apr 20, 2016 @necromant2005 Thanks, worked for me on Debian 8.3 too! Is it a mandatory step? Cannot Find Openssl's Evp.h Centos

I've checked config.log and there're nothing about openssl at the end - HAVE_WORKING_BOOST_SLEEP_FOR refers to checking for dynamic linked boost test... There is a good chance that a standard install of libcog will fix the problem. it gives me following error in this file, CMakeLists.txt -------- line ---> find_package(OpenSSL REQUIRED) :-- cmake .. -- Could NOT find Git (missing: GIT_EXECUTABLE) ZLib include dirs: /usr/include ZLib libraries: /usr/lib/arm-linux-gnueabihf/libz.so navigate here no Anyway, glad everything worked out.

However, when I edited configure and hard coded OPENSSL_LIBDIR to my openssl path it worked fine. Fatal Error: Pcre.h: No Such File Or Directory This will usually cover system installed modules. more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science

How to prove that authentication system works, and that customer uses the wrong password?

These files are named after the package, with the extension .pc. The pkg-config script it uses to find the development files for those libraries, outputs this message. Browse other questions tagged ubuntu openssl configure or ask your own question. Cannot Find Openssl Libraries I locate the file i want e.g.

This is a follow-up to bug 25703 (I added a note on Nov. 20) and is also related to bug 25719. asked 1 year ago viewed 3635 times active 1 year ago Related 31OpenSSL missing during ./configure. Can I use that to take out what he owes me? http://rss4medics.com/cannot-find/pecl-cannot-find-config-m4-apd.php yes checking for X509_free in -lcrypto...

yes checking for Kerberos support... share|improve this answer answered Jan 7 at 15:43 ychaouche 1369 add a comment| up vote 0 down vote I had the same problem on Fedora 19 despite having OpenSSL installed. How to reply? Here's what worked for me : [email protected][10.10.10.82] ~/DOWNLOADS/php-5.5.23/ext/mysqlnd # PHP_OPENSSL_DIR="/usr /usr/lib/x86_64-linux-gnu" [email protected][10.10.10.82] ~/DOWNLOADS/php-5.5.23/ext/mysqlnd # ./configure --with-libdir="" [...] checking for DSA_get_default_method in -lssl...